Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 22, 2026 - 23:00 SAST
Scheduled
Scheduled Maintenance: Data Centre UPS Infrastructure Upgrade Date: 22 January – 22 February 2026 Status: Scheduled Impact: No Service Impact Expected
Overview Our Data Centre provider has notified us of a critical infrastructure upgrade involving the Uninterruptible Power Supply (UPS) systems serving our facility. This maintenance is required to ensure the highest levels of power redundancy and stability for our infrastructure moving forward.
While the broader maintenance window is scheduled from 22 January to 22 February, specific activity affecting our cabinets will occur on selected dates listed below.
Maintenance Schedule Work will be performed on the following dates for our cabinets:
January 22 – 23
February 11 – 12
February 18
Times: 23:00 - 06:00 Length: 7 hours
Client Impact: None Expected We anticipate no disruption to client services during this operation. However we are aware that an outage is possible based on the nature of the Maintenance being performed.
Our infrastructure is architected for full high-availability with redundant power feeds. All critical equipment is connected to dual Power Distribution Units (PDUs) (Feed A and Feed B).
When power is cycled on one PDU, the equipment will automatically and seamlessly draw power from the redundant feed.
Our Data Centre provider is fully aware of the criticality of our services and will be closely monitoring all systems during the changeover to ensure stability.
Technical Procedure For transparency, the upgrade will follow this strict three-step protocol to maintain continuous uptime:
Isolation: Power will be switched off on one side of the PDU (e.g., Side A). All equipment loads will temporarily run entirely on the redundant opposite side (Side B).
Upgrade: Existing supply cables on the isolated side will be disconnected and replaced with cables fed from the new UPS system. These will be rigorously tested and commissioned.
Rotation: Once the first side is active and stable, the process will be repeated for the opposite side (Side B), with the load transferring to the newly upgraded Side A.
Our Infrastructure team will be monitor our systems during these periods and have remote hands onsite if required.
Please contact vps@metrofilecloud.com if you have further questions or require assistance.
Posted Jan 22, 2026 - 15:19 SAST
This scheduled maintenance affected: Redstor Backup, VPC Hosting, VPS Hosting, Everfiles, S3, Internet Connectivity and Backup and Protect (Backup Storage).