Security Updates and RDP Tooling Patch

Incident Report for Metrofile Cloud

Update

Updated Maintenance Schedule

18:00 – RDP Tool Update & Server Reboots
The RDP Tool update has been deployed. Any servers that have not yet completed the update will be rebooted at 18:00 to finalize the installation ahead of this evening's maintenance window.

20:00 – Windows Server Security Patching
Scheduled Windows Server security patching will commence at 20:00 as part of our regular maintenance cycle to ensure all systems receive the latest Microsoft security updates.

Post-Maintenance Verification
We recommend testing connectivity to your systems once the maintenance window has completed.

If you experience any issues accessing your systems after the maintenance window, please contact our after-hours support team:

Email: support@irontree.co.za
Phone: 076 102 9813

Our team will be available to provide prompt assistance if required.
Posted Jul 17, 2026 - 13:44 SAST

Identified

Microsoft has released critical security updates for Windows Server as part of its July 2026 Patch Tuesday.

Details here: https://www.bleepingcomputer.com/news/microsoft/microsoft-july-2026-patch-tuesday-fixes-massive-570-flaws-3-zero-days/

We will deploy these updates this weekend as part of our scheduled patching cycle.
To ensure continued secure and reliable connectivity to your systems, we are also rolling out an update to our RDP tooling across our client base ahead of the Windows patching. This update can be applied to live systems without disruption, but requires a reboot, which our technical team will perform out of hours.

Schedule:
Tonight (after hours): RDP tooling update and reboots
Tomorrow night: Windows Server security patching

In some niche cases with clients with older versions, a reboot during the day may be required.

No action is required from your side. If you experience any connectivity issues following the maintenance windows, please contact our support team.
Posted Jul 16, 2026 - 12:27 SAST
This incident affects: VPC Hosting and VPS Hosting.