Data Centre Outage

Incident Report for Metrofile Cloud

Postmortem

Posted Jun 09, 2025 - 13:42 SAST

Resolved

We understand the importance of uninterrupted service and sincerely regret any inconvenience this incident may have caused to your operations.

At this time, we are satisfied that all affected systems are operating normally.

We will share the Root Cause Analysis (RCA) report as soon as we receive it from our Data Centre Provider.

Thank you for your patience and understanding.
Posted May 22, 2025 - 11:24 SAST

Update

All systems are online and stable, we will be monitoring over night.

Please contact vps@metrofilecloud.com if you are still experiencing issues.
Posted May 21, 2025 - 23:58 SAST

Update

We have picked up an issue with some clients experiencing network issues still, please notify vps@metrofilecloud.com if you are unable to access your system.

We apologise for the disruption caused to your business.

We are waiting feedback from our DC provider on the outage.
Posted May 21, 2025 - 20:26 SAST

Monitoring

Power has been restored and we are investigating issues relating to the outage.
Posted May 21, 2025 - 18:27 SAST

Update

We are continuing to work on a fix for this issue.
Posted May 21, 2025 - 17:40 SAST

Identified

We have identified the issue as a Data Centre wide power outage, we have deployed technicians to the DC and we are busy reapirong systems.
Posted May 21, 2025 - 17:24 SAST

Investigating

We are currently investigating an internet outage with our ISP's.
Posted May 21, 2025 - 17:06 SAST
This incident affected: Redstor Backup, VPC Hosting, VPS Hosting, Disaster Recovery, Everfiles, S3, Internet Connectivity and Backup and Protect (Backup Storage).