IronTree Disaster Recovery - Web Console Outage

Incident Report for Metrofile Cloud

Resolved

Issue has been resolved
Posted Sep 23, 2024 - 10:50 SAST

Investigating

We are currently investigating a Web Console outage from our Service Provider
Posted Sep 23, 2024 - 09:45 SAST
This incident affected: Redstor Backup.