Incident has been resolved and backups have been caught up and running for several days.
Posted Apr 17, 2025 - 14:38 SAST
Monitoring
We have identified and resolved the issue.
We are currently catching up on any pending backups and monitoring the system.
Posted Apr 11, 2025 - 17:00 SAST
Update
We are continuing to investigate this issue.
Posted Apr 11, 2025 - 03:40 SAST
Investigating
We are currently investigating a network issue causing some failed/timed-out backups. This is also affecting any restores older than 3 days resulting in delayed restore times.