Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 17, 2025 - 17:00 SAST
Scheduled
Please be advised that scheduled maintenance will be performed on our critical storage systems this weekend.
This essential work is aimed at enhancing system performance and facilitating the integration of new equipment within the Data Centre.
Date: 17 May 2025 Time: 17:00 SAST Duration: Approximately 12 hours
Our objective is to complete this maintenance without any impact on client services. However, due to the inherent complexities of storage systems, unforeseen issues may arise. Should you experience any service disruptions following the maintenance window, please contact our support team at vps@metrofilecloud.com.
We appreciate your understanding as we work to improve our infrastructure.
Posted May 16, 2025 - 10:45 SAST
This scheduled maintenance affected: Redstor Backup, VPC Hosting, Everfiles, S3 and Backup and Protect (Backup Storage).