Everfiles Login Issues

Incident Report for Metrofile Cloud

Monitoring

We have identified the issue and applied the fix. We are continuing to monitor for any further issues.
Posted Aug 13, 2026 - 09:30 SAST

Investigating

We are aware of a login issue with Everfiles and we are currently investigating. We will provide updates as the investigation and resolution progresses.
Posted Aug 13, 2026 - 09:11 SAST
This incident affects: Everfiles.