Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 26, 2025 - 08:00 SAST
Scheduled
We will be updating our Acronis ACI to a new version for compatibility improvements and stability. There will be no expected downtime or affect on clients during this update.
Time: 08:00-15:00 Length: 7 hrs
Posted Oct 24, 2025 - 10:22 SAST
This scheduled maintenance affected: Backup and Protect (Backup Storage).