Intermittent Calling Issues

Incident Report for Metrofile Cloud

Resolved

Our pbx system is fully operation.
Posted Jul 31, 2026 - 16:47 SAST

Investigating

We have noticed that calls to and from our Office Line are dropping intermittently. We have logged an urgent request with our PBX Provider and they are actively investigating the issue. If you are unable to reach us on our Landline, please log a Ticket with the relevant department.

accounts@irontree.co.za
techsupport@irontree.co.za
sales@irontree.co.za
vps@irontree.co.za

For urgent assistance, please contact us on our After Hours Numbers:

072 595 1066 - Tech Support
076 102 9813 - Hosting Support

Further updates to follow as soon as feedback has been received from our Vendor.
Posted Jul 31, 2026 - 10:46 SAST